Changeset bb68e27 in theo


Ignore:
Timestamp:
11/26/2022 08:51:18 PM (2 months ago)
Author:
Lance Edgar <lance@…>
Branches:
master
Children:
32d7466
Parents:
4a983f6
Message:

Remove version cap for mysql-connector-python

live demo now runs on python 3.9.2 and so whatever issue i ran across
previously, is no longer a thing i guess.

maybe should officially declare python 3.9 classifier? perhaps better
to add mysql version cap back in, for certain python versions? for
now i'm feeling like just this is good enough

File:
1 edited

Legend:

Unmodified
Added
Removed
  • setup.py

    r4a983f6 rbb68e27  
    7777
    7878        'invoke',                       # 1.4.1
     79        'mysql-connector-python',
    7980        'psycopg2',                     # 2.8.5
    8081        'rattail[db,auth,bouncer]',     # 0.9.130
    8182        'Tailbone',                     # 0.8.97
    82 
    83         # we include mysql "always" even though it may not be actually needed
    84         # TODO: must cap this for now, b/c it breaks CORE-POS integration?!
    85         # (sometimes there are segfaults with basic grid queries)
    86         # 'mysql-connector-python==8.0.17',
    87         # TODO: was having trouble getting 8.0.17 to work on Ubuntu 20.04 with
    88         # MySQL 8.0.21 and so am trying this out...
    89         'mysql-connector-python',
    9083    ],
    9184
     
    107100        # package                       # low                   high
    108101
    109         # TODO: this also is an experiment.  see notes above in 'app' extra.
    110         # am still getting segfaults with 8.0.23 so this seems necessary
    111         'mysql-connector-python==8.0.17',
    112102        'pyCOREPOS',                    # 0.1.0
    113103        'rattail-corepos',              # 0.1.0
Note: See TracChangeset for help on using the changeset viewer.